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Purpose of this document   

Aloha Kitchen v19.3.x comes with a number of enhancements to aid you in the successful 
operation of your kitchen. You activate and configure these enhancements to best meet 
your operational needs.

This document contains instructions on how to configure and use the enhancements 
implemented in Aloha Kitchen v19.3.x. When applicable, we include a scenario, how to 
configure the feature in the Back-of-House (BOH), how to use the feature on the video 
controller, and references to other materials to fully implement the feature.

Refreshing the data
After all settings are in place in your configuration tool (Aloha Manager or Aloha 
Configuration Center), you must select Utilities > POS > Refresh POS and All Installed 
Products to transfer the new information to the FOH terminals, or wait for the End-of-Day 
(EOD) process to accomplish the data refresh for you. If you run the refresh prior to the 
End-of-Day process, select ‘Automatically restart all POS terminals’ and click OK to continue. 
After the data refresh is complete, all new settings become operational across the Aloha 
network.

Feature Name at a Glance

Core Product NCR Aloha Quick Service and NCR Aloha Table Service
Complementary Products NCR Aloha Kitchen
Separate License Required? Yes
Other References NCR Aloha Kitchen Getting Started Guide, Customizing 

Aloha Kitchen Guide

Caution:  Refresh data with caution and never during peak hours of operation. All 
FOH terminals reboot during a refresh and are down for a short period of time.
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List of enhancements  
Released 
Version

Tracking 
Number

Description

AK v19.1 ALOHAP-05407 “Embedding a URL in Recipe Viewer” on page 3
AK v19.1 ALOHAP-05417 “Introducing Forecast Estimate Bin Report” on page 7
AK v19.1.8 ALOHAP-05417 “Manually wasting an item for a forecast bin” on page 8
AK v19.4 ALOHAP-08806 “Introducing Production Assembly Line” on page 11
AK v19.2 ALOHAP-12229 “Communicating with the Aloha POS using Aloha API and COM” on 

page 12
AK v19.2 ALOHAP-13648 “Supporting POS coursing in Aloha Kitchen” on page 13
AK v19.2 ALOHAP-13666 “Simplifying the creation of the Customer Order Display screen” on 

page 15
AK v19.2 ALOHAP-14190 “Enhancing production chits in Print Designer” on page 16
AK v19.2.11 ALOHAP-15251 “Defining AK speed of service target for NCR Pulse” on page 27
AK v19.2 ALOHAP-18372

ALOHAP-23608
“Printing rewards member on production or order taker chit” on 
page 30

AK v19.2 ALOHAP-18376 “Supporting ‘Custom paid line text’ element” on page 33
AK v19.2 ALOHAP-18509 “Supporting Windows printer for drivers” on page 35
AK v19.3.6 ALOHAP-18869 “Printing consumer name on production chit” on page 38
AK v19.2 ALOHAP-19992 “Printing multiple bag chits for a single order” on page 42
AK v19.2 ALOHAP-21530 “Disabling bump bars by station for staff levels” on page 44
AK v19.3.6 ALOHAP-23513 “Displaying checked-in icon and text on video screen” on page 45
AK v19.3.6 ALOHAP-23512 “Displaying vehicle information on video screen” on page 49
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Embedding a URL in Recipe Viewer

Some sites and corporations invest valuable time and money on the creation of 
instructional videos to virtually train their kitchen staff in lieu of gathering employees to a 
location at a specific time. The Task Info and Recipe Viewer functions in Aloha Kitchen 
already support embedded media files housed on the file server; however, sites want to 
store media on a website they can update, and prevent the need to continually send files or 
links to their stores. You can now embed a URL in the Recipe Viewer function of Aloha 
Kitchen, allowing the kitchen staff to access up-to-date company information from the 
terminals. The feature supports an unlimited number of uploaded links 

Configuring an Embedded URL in Recipe Viewer
To embed a URL in Recipe Viewer, you must create a task in the Task Info function with an 
embedded URL and then associate the task in the Recipe Viewer function. 

To create a task info record with an embedded URL: 

1. With Kitchen selected in the product panel, select Maintenance > Kitchen 
Configuration > Task Info. 

2. Click New. 

3. Type a descriptive name for the task, such as ‘Training Video.’ 

4. Do not select an item from the ‘Item’ drop-down list. 

Released 
Version

Tracking 
Number

Products Audience

AK v19.1 ALOHAP-05407 Aloha Kitchen, Aloha Quick Service, Aloha 
Table Service

Configuration Technician
End User

Caution:  This feature requires Internet access from the kitchen controller, and only 
supports Windows 2007 and higher. It is the responsibility of the site administrator 
to provide a secure network environment that includes firewall configuration, 
updated web browsers, and any other elements to maintain PCI compliance. An 
unsecured browser could put sensitive data at risk or expose it to malicious content. 
For any questions, contact your NCR representative or the NCR Data Security team.
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5. Select the Links tab. 

6. Click Add. 

7. Under the ‘Display name’ column, type the name to appear in Recipe Viewer. 

8. Under the ‘Link’ column, type the URL that launches the web page. 

9. Click Save. 

10. Repeat this procedure to associate another URL with another task. 

11. Exit the Task Info function. 

As with any task info record, you must associate it to a category in the Recipe Viewer 
function so an employee can access and view it from the terminal. 

To associate a task in Recipe Viewer: 

1. With Kitchen selected in the product panel, select Maintenance > Kitchen 
Configuration > Recipe Viewer. 

2. Under the ‘Settings’ group bar, right-click on root, and select Add category from the 
menu that appears. 

3. Type a name for the category, such as ‘Training Video.’ 

4. Select the Task Infos tab. 

Figure 1  Task Info - Links Tab
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5. Under the ‘Task Infos’ group bar, select and drag the task you created to the left and 
release it under the appropriate category. In keeping with the example, release under 
‘Training Video’ on the left. 

6. Click Save and exit the Recipe Viewer function. 

Using an Embedded URL in Recipe Viewer
You launch an embedded URL through the Task Info command on the kitchen screen and 
use the commands from the Recipe Viewer keypad, either from a touch-screen controller or 
a bump bar. When the Recipe Viewer screen appears, the Recipe Viewer keypad is in focus 
and overrides the commands on the bump bar. When you press Close on the Recipe Viewer 
keypad, the commands revert back to the original commands configured for the bump bar.  

Figure 2  Recipe Viewer Function

Figure 3  Recipe Viewer Keypad to Bump Bar Button Equivalency

recipe viewer 
keypad

bump bar
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To use an embedded URL in recipe viewer: 

1. From the Kitchen screen, select Task Info. The Recipe Viewer screen appears with the 
Recipe Viewer keypad. 

2. Select the Links button. The ‘Pick item’ screen appears.  

3. Select the link and then touch Select. A website opens in a supported browser. 

4. Complete the required task, such as watching a training video. 

5. Touch Close to exit the screen. 

Figure 4  Pick Item Screen

Note:  If you do not have an Internet connection, the ‘Pick item’ screen does not appear. 
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Introducing Forecast Estimate Bin Report

The data used for the existing Forecast report reads historical sales information from four 
previous weeks of subdirectories, or from NCR BackOffice, to predict the quantity of items 
needed in the bin for a specific time interval. You can also set a minimum quantity required 
for the time interval in the Forecasting function for instances where the quantity from the 
historical data might dip below the number needed in the bin; however, the Forecast report 
does not respect the minimum quantities. 

Effective in Aloha Kitchen v19.1.8, we introduce a new Forecast Estimate report which 
includes the required minimum quantity. This allows sites to compare the historical sales 
information in a more efficient manner and better operate their business. In addition, you 
can choose a future day within the next two weeks so you can increase your forecast 
outlook.  

Released 
Version

Tracking 
Number

Products Audience

AK v19.1.8 ALOHAP-05417 Aloha Kitchen, Aloha Quick Service, Aloha 
Table Service

Configuration Technician
End User

Figure 5  Forecast Estimate Report

Reference:  Refer to the Forecast Bins Feature Focus Guide for information on configuring and 
using forecast bins. 
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Manually wasting an item for a forecast bin

This feature is still in development and is not fully functional. We will update the docu-
mentation when the feature reaches optimal functionality. 

Currently, when an item appears in the ‘Cooked’ column on a forecast bin and the item is 
never bumped from the kitchen screen, the system automatically moves it to the ‘Waste’ 
column based on the number of seconds defined in ‘Shelf life in seconds’ in the Bin function. 
The item remains in the ‘Waste’ column until the next interval arrives and the forecast bin 
repopulates with new quantities. 

Effective in Aloha Kitchen v19.1.8, you can manually ‘waste’ an item on a forecast bin 
without waiting for the shelf life seconds to expire. In addition to this enhancement, you can 
enter a portion of an item to waste. For example, if you drop one-third or an order of fries 
on the floor, you can enter 0.33; however, the bin quantity decrements only when you waste 
a whole number. 

To configure the ability to manually waste an item for a forecast bin: 

1. With Kitchen selected in the product panel, select Maintenance > Kitchen 
Configuration > Bin. 

2. Select a forecast bin in use from the drop-down list. 

3. Under the ‘Settings’ group bar, select Allow forecast waste adjustment. 

Allow forecast waste adjustment — Enables you to manually waste an item, or portion of
an item, from a forecast bin, instead of waiting for the shelf life seconds to expire. When you
select the Waste button on the Forecast Bin Drop Adjustment Bar, an additional keypad
appears allowing you to enter a quantity, or a portion of a quantity, to waste. The bin quan-
tity decrements only when you waste a whole amount. 

4. Click Save. 

Released 
Version

Tracking 
Number

Products Audience

AK v19.1.8 ALOHAP-05417 Aloha Kitchen, Aloha Quick Service, Aloha 
Table Service

Configuration Technician
End User

Figure 6  Forecast Bin Area
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5. Repeat this procedure for each forecast bin for which to allow manual waste of items. 

6. Exit the Bins function. 

To manually waste an item for a forecast bin: 

1. For a touch-screen controller, touch the bin area to display a virtual bump bar as a 
forecast bin drop bar and select Waste. For a bump bar, press the corresponding button 
position that aligns with Waste on the virtual bump bar. 

Figure 7  Forecast Bin (Top) Forecast Bin Drop Bar (Below) 

forecast bin 
area

virtual bump bar 
as a forecast bin 
drop bar

Waste
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The Enter amount to Waste screen appears. The virtual bump bar appears with a 
numeric keypad.  

2. For a touch-screen controller, touch the quantity to waste and then touch Select. For a 
bump bar, press the corresponding button positions that align with the quantity to 
waste on the virtual bump bar and then press Select. If you want to waste a portion of 
an item, enter the quantity with a decimal. 

The system returns you to the kitchen screen with the selected quantity in the ‘Waste’ 
column. If you entered a portion of an item, the system moves the quantity when a 
whole number is reached. 

Figure 8  Enter Amount to Waste Screen

virtual bump bar 
as a numeric 
keypad 
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Introducing Production Assembly Line 

Many quick service restaurants utilize a make-line type of operation where one kitchen 
employee is responsible for adding or preparing one part or section of a menu item, and it 
is then passed to another employee to add or prepare the next part. The ingredients are 
pulled from individual ‘hotel pans’ displayed in front of the employee. The flow continues 
until the menu item is completely built. You see this concept in restaurants that serve 
burgers, pizzas, steam-table buffet lines, sandwiches, subs, Mexican food, and many other 
environments. 

This type of operation:

● Enforces consistency through repetition. 

● Requires limited training. 

● Creates a more efficient and effective production environment. 

● Increases your speed of service to each consumer who walks through the door. 

To accommodate this environment, Aloha® Kitchen uses production assembly line screens 
where the configuration spans across several functions. You design the production screens 
to simulate the layout of the hotel pans on the make-line. When an order appears on the 
screen, the ingredients needed to fulfill the order appear highlighted on the screen so the 
employee can easily build the item and move on to the next order. 

Released 
Version

Tracking 
Number

Products Audience

AK v19.2 ALOHAP-08806 Aloha Kitchen, Aloha Quick Service, Aloha 
Table Service

Configuration Technician
End User

Figure 9  Make-Line Environment Illustration

Reference:  Refer to the Production Assembly Line Feature Focus Guide for more information. 
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Communicating with the Aloha POS using Aloha API and 
COM 

Effective in Aloha® Kitchen (AK) v19.2, AK can communicate with the Aloha POS using Aloha 
API or COM, based on the installed version of the Aloha POS. This provides seamless 
communication between the two Aloha products. This new approach resolves isolated 
routing issues, such as when items and orders do not appear correctly on production and 
expo screens. 

If you couple Aloha Kitchen with POS v15.1, or earlier, AK communicates through COM. If 
you couple Aloha Kitchen with Aloha POS v19.3, or later, AK communicates through the 
Aloha API. The connection occurs automatically, including upon an upgrade, and there is no 
configuration required for this implementation. 

Released 
Version

Tracking 
Number

Products Audience

AK v19.2 ALOHAP-12229
ALOHAP-21735

Aloha Kitchen, Aloha Quick Service, Aloha 
Table Service

Configuration Technician
End User
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Supporting POS coursing in Aloha Kitchen 

This feature is still in development and is not fully functional. We will update the docu-
mentation when the feature reaches optimal functionality. 

Aloha® Kitchen has a variety of methods to configure coursing within the product; however, 
it does not respect the coursing methods used in the Aloha POS system. Effective in AK 
v19.2, Aloha Kitchen now supports the POS coursing in the Aloha POS system. 

To configure Aloha Kitchen to respect Aloha POS course numbers:

1. With Kitchen selected in the product panel, select Maintenance > Kitchen 
Configuration L Kitchen Settings. 

2. Select Support POS course numbers. 

3. Click Save and exit the Kitchen Settings function. 

To associate a POS course number to an existing AK course:

1. With Kitchen selected in the product panel, select Maintenance > Kitchen 
Configuration > Course. 

2. Select a course in use from the drop-down list. 

3. Type the corresponding POS course number for the course. 

4. Click Save. 

Released 
Version

Tracking 
Number

Products Audience

AK v19.2 ALOHAP-13648 Aloha Kitchen, Aloha Quick Service, Aloha 
Table Service

Configuration Technician
End User

Reference:  Refer to the Coursing Feature Focus Guide for more information on coursing in the 
Aloha POS system.

<KitchenSettings>
<Number>1</Number>
<SupportPOSCourseNumbers>True</SupportPOSCourseNumbers>
</KitchenSettings>
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5. Repeat this procedure for each AK course you want to associate a POS course number. 

6. Exit the Course function. 

To add a course timer to a header and footer layout: 

1. With Kitchen selected in the product panel, select Maintenance > Kitchen 
Configuration > Header and Footer Layout. 

2. Select a layout from the drop-down list. 

3. Select the Design tab. 

4. Click the Add drop-down arrow, select Course timer, and click OK. 

5. Configure the line number, location, and style, as you would for any other element. 

6. Click Save. 

7. Repeat this procedure for any other layout you want to add a course timer element. 

8. Exit the Header and Footer Layout function. 

To configure the release of a suspended course when a previous course is served:

1. With Kitchen selected in the product panel, select Maintenance > Kitchen 
Configuration > Kitchen Settings. 

2. Select Release suspended course when previous course is served. 

3. Click Save and exit the Kitchen Settings function. 

<Course>
<POSCourseNumber>1</POSCourseNumber>
</Course>

<HeaderFooterLayoutElement>
<ElementType>68</ElementType>
</HeaderFooterLayoutElement>

<KitchenSettings>
<Number>1</Number>
<ReleaseSuspendedCourseWhenPreviousCourseIsServed>True</ReleaseSuspendedCo
urseWhenPreviousCourseIsServed>
</KitchenSettings>
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Simplifying the creation of the Customer Order Display 
screen 

This feature is still in development and is not fully functional. We will update the docu-
mentation when the feature reaches optimal functionality. 

For orders to display on a customer order display, you must create an HTML file and upload 
it into CFC. Some customers may not have experience in creating HTML code and find the 
implementation too complex. We now offer two professional templates written in HTML 
that offer the ability to minimally customize the screen, such as the background color, 
images, and order states. 

Currently, you can create HTML files to customize the customer order display screen; 
however, the implementation is complex and overwhelming. We will now offer a more 
simplified solution to customizing the customer order display and provide templates for 
customers to use with minimal modifications. such as saving a Word document as HTML.

Released 
Version

Tracking 
Number

Products Audience

AK v19.2 ALOHAP-13666 Aloha Kitchen, Aloha Quick Service, Aloha 
Table Service

Configuration Technician
End User
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Enhancing production chits in Print Designer 

With delivery and takeout operations continuing to expand in the marketplace, restaurants 
want more flexibility in designing the kitchen chit (production chit) to meet their operational 
needs. The kitchen chit is used at various end-points during the life of an order. It first 
serves as a communication to the kitchen staff to assist with proper preparation of an order. 
You then staple it to a bag or lay it on a tray for delivery by a food runner. Finally, the 
consumer receiving the order uses it to verify the order is correct. In summary, the kitchen 
chit acts as the printed representation of the order, reduces the number of errors in 
preparation, and must be organized so that it is beneficial to each actor. 

Effective in Aloha® Kitchen v19.2, you can use the production chit layout in the Print 
Designer function to implement any of the following enhancements to organize the kitchen 
chit. 

Released 
Version

Tracking 
Number

Products Audience

AK v19.2 ALOHAP-14190
ALOHAP-15157
ALOHAP-15483
ALOHAP-15640
ALOHAP-15801
ALOHAP-16814
ALOHAP-17725

Aloha Kitchen, Aloha Quick Service, Aloha 
Table Service

Configuration Technician
End User

Figure 10  Enhanced Production Chit Example
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● Group and print items based on categories. 

● Apply line attribute overrides, such as bold and italics, to menu items and modifiers on 
the kitchen chit. 

● Assign an image to each menu item, for printing on the kitchen chit.

● Assign an image to each modifier code, for printing on the kitchen chit.

● Associate a production chit with each order mode. 

Grouping and printing items by categories 

Currently, items appear on the chit in the order in which you add them to the check, or using 
a defined priority. You can now group and print items using general (non-sales) categories 
to organize the kitchen chit. For example, you can group items by:

● Courses, such as appetizers, entrees, and desserts.

● Stations, such as grilled, fried, and cold.

● Length of time to prepare, such as two minutes, three minutes, five minutes. 

To do this, assign items to general categories in the Categories function, and then use the 
Chit Item Category Grouping function to group the categories. We recommend putting an 
item in only one of these categories. Once grouped, all production chit layouts defined in 
the Print Designer function use that grouping. Any item not assigned to a category within 
the grouping prints independently. You can configure only one Chit Item Category Grouping 
record, per store. If you later decide you do not want the grouping, delete the Chit Item 
Category Grouping record. 

To assign items to a general category:

1. With Kitchen selected in the product panel, select Maintenance > Menu > Categories. 

2. Click the New drop-down arrow, select General, and click OK. 

3. Type a name for the category, such as ‘Apps.’

4. Select the Items tab. 

Reference:  Refer to the Print Designer Feature Focus Guide for more information on configuring 
and using Print Designer.

Figure 11  Grouping Items on Kitchen Chit Example
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5. Select an item from the ‘Available’ list and click >> to move the item to the ‘Included’ list. 

6. Repeat step 5 to include each item in the category. 

7. Click Save. 

8. Repeat this procedure until you assign all necessary items to a category. 

9. Exit the Categories function. 

To assign categories for chit item category grouping:

1. With Kitchen selected in the product panel, select Maintenance > Hardware > Print 
Designer Configuration > Chit Item Category Grouping. The Chit Item Category 
Grouping function appears. 

2. Under the ‘Groupings’ group bar, click Add. 

3. Select a category to include in the production chit grouping from the ‘Category’ 
drop-down list. 

Category — Allows you to select a general category to include in the grouping. The order in
which a category appears here is the order in which it prints on the production chit. Docu-
mented Version: AK 19.3. 

4. Type the name to identify the category in ‘Group Header,’ if different than the default 
text. 

Figure 12  Chit Item Category Grouping Function
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Group header — Denotes the name to appear for the grouping on all production chit lay-
outs created in Print Designer. The name of the category appears as the default text, but
you can use an alternate name that is more descriptive or friendly. To have more than one
category appear as though it belongs to a single category, type the same group header for
each applicable category. Documented Version: AK 19.3. 

5. Repeat steps 2 through 4 until you group all the necessary categories. 

6. Click Save and exit the Chit Item Category Grouping function. 

Applying line attribute overrides to menu items and modifiers 

Currently in Print Designer, you can configure elements to print in a smaller or larger font 
size and define the text alignment. Now you can add other basic text attributes, such as bold 
and italics, and print the element in a color of your choice. This allows an element to stand 
out while other elements print normally. 

Previously, the modifiers that accompany the menu items inherit the same attributes and 
there is no distinction between items and modifiers on a layout. We separated modifiers 
from the Items element and you can customize modifiers independently. For example, you 
can specify items to appear as large and in bold, and modifiers to appear as small and in 
italics. You cannot customize attributes for a specific item or modifier. 

To apply line attribute overrides to menu items and modifiers:

1. With Kitchen selected in the product panel, select Maintenance > Hardware > Print 
Designer Configuration > Print Designer. 

2. Select a production chit in use from the drop-down list. 

Figure 13  Line Attributes Applied to Item and Modifier
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3. Select the Design tab.  

4. Under the ‘Design’ group bar, click the Add drop-down arrow, select either Items or 
Modifiers, and click OK. 

5. Under the ‘Line attribute overrides’ group bar, select Use line attribute overrides. 

Use line attribute overrides — Enables you to use additional basic text attributes, such as
bold, italic, and underlined, and to print the element in a color of your choice. This allows an
element to stand out while other elements print normally. Selecting this option exposes the
remaining options in the group bar. Documented Version: AK 19.3. 

6. Select the color in which to print the text of the element from the ‘RGB color settings’ 
palette, as desired. 

RGB color settings — Specifies the color in which to print the text of the element. The
default is 0.0.0. You must use a color printer. Documented Version: AK v19.3. 

7. Select Italic, as desired. 

Italic — Prints the text of the element in italic. Documented Version: AK v19.3. 

8. Select Underlined, as desired. 

Figure 14  Print Designer - Design Tab
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Underlined — Prints the text of the element with an underline. Documented Version: AK
v19.3. 

9. Select Bold, as desired. 

Bold — Prints the text of the element in bold. Documented Version: AK v19.3. 

10. Repeat steps 4 to 9 for any other element for which to override the standard printing. 

11. Click Save and exit the Print Designer function. 

Printing an image with a menu item 
You can designate an image to print to the left of a menu item on a production chit created 
in Print Designer. You may want to do this to promote signature items or identify generic 
items, such as an image of a drink for your drink items. You could also use an image to 
indicate the serving temperature recommended for items, such as HOT for a coffee, or use 
an image containing the first letter of an item, such as the letter B for a burrito. 

Figure 15  Item with Image
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To designate an image to print to the left of a menu item on a production chit:

1. Select Maintenance > Menu > Items > Item tab. 

2. Under the ‘Settings’ group bar, select the image to print to the left of the menu item 
from the ‘Kitchen chit item image’ drop-down list. 

Kitchen chit item image — Designates the image to print to the left of the menu item on a
kitchen chit, when using a production chit layout in Print Designer. You may want to do this
to promote signature items or identify generic items, such as an image of a drink for your
drink items. You could also use an image to indicate the serving temperature recommended
for items, such as HOT for a coffee, or use an image containing the first letter of an item,
such as the letter B for a burrito. We recommend using 22x22 as the dimensions for your
image. Required Options: You must import the image using the Aloha Kitchen application
type in the Media Files function to make the image available in the drop-down list. Docu-
mented Version: AK v19.3.

3. Click Save. 

4. Repeat this procedure for any other menu item for which to designate an image. 

5. Exit the Items function. 

Figure 16  Items - Items Tab
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Printing an image based on modifier code 

You can designate an image to print to the left of a modifier code on a production chit 
created in Print Designer. You might use a plus sign for a modifier added to an item (Add), a 
minus sign for a modifier removed from an item (No), and others. You could also use an 
image with the word ADD or NO. 

To designate an image to print to the left of a modifier code on a production chit:

1. Select Maintenance > Menu > Modifier Codes.

2. Select a modifier code. 

3. Under the ‘Settings’ group bar, select the image to associate with the modifier code from 
the ‘Kitchen modifier image’ drop-down list. 

Figure 17  Modifier Code with Image

Figure 18  Modifier Codes Function
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Kitchen modifier image — Designates the image to print to the left of a modifier code on a
kitchen chit, when using a production chit layout in Print Designer. You may want to use a
plus sign for a modifier added to an item (Add), a minus sign for a modifier removed from
an item (No), and others. You could also use an image with the word ADD or NO. We recom-
mend using 22x22 as the dimensions for your image. Required Options: You must import
the image using the Aloha Kitchen application type in the Media Files function to make the
image available in the drop-down list. Documented Version: AK v19.3.

4. Click Save. 

5. Repeat this procedure for any other modifier code for which to designate an image. 

6. Exit the Modifier Code function. 

Associating a production chit layout with an order mode 
You can associate a production chit layout designed in Print Designer for use with a specific 
order mode. For example, to print a production chit layout specifically for takeout orders, 
attach the layout to the Takeout order mode. Aloha Kitchen uses the layout to print the chit 
each time you place a takeout order. This option overrides the default layout selected in the 
‘Item chit layout’ drop-down list in Maintenance > Kitchen Configuration > Kitchen Settings. 

To associate a production chit layout with an order mode:

1. With Kitchen selected in the product window, select Maintenance > System Settings > 
Order Mode. 

2. Select the Kitchen tab. 
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3. Select an order mode from the drop-down list. 

4. Select the layout from the ‘Print layout override’ drop-down list. 

Print layout override — Specifies the production chit layout designed in Print Designer to
use for printing the chit when you apply this order mode. Related Options: The ‘Print layout
override’ option overrides the layout defined in Maintenance > Kitchen Configuration >
Kitchen Settings. Documented Version: AK v19.3. 

5. Click Save. 

6. Repeat this procedure for each order mode for which to print an override production 
chit. 

7. Exit the Order Mode function. 

Summary
In summary, you can implement all or any of these enhancements to customize the kitchen 
chit to meet your operational needs. You must use a production chit type in the Print 
Designer function. After all settings are in place in your configuration tool (Aloha Manager or 
Aloha Configuration Center), you must select Utilities > POS > Refresh POS and All Installed 
Products to transfer the new information to the FOH terminals, or wait for the End-of-Day 
(EOD) process to accomplish the data refresh for you. If you run the refresh prior to the 
End-of-Day process, select ‘Automatically restart all POS terminals’ and click OK to continue. 

Figure 19  Order Modes - Kitchen Tab 
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After the data refresh is complete, all new settings become operational across the Aloha 
network. 
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Defining AK speed of service target for NCR Pulse 

Effective in Aloha Kitchen® v19.2, you can define the target speed of service and send data to 
an NCR Pulse user to see trending lines on graphical charts in red. This allows the Pulse user 
to monitor the status of orders in their restaurant. 

Prior to configuration, you must install the PulseAgent plug-in as a service to allow Aloha 
Kitchen to send data to Pulse. 

To install the AKPulse plug-in:

1. Obtain the PulseAgent.msi from the Pulse support team and place it in a staging 
directory. 

2. Run the PulseAgent.msi. Upon completion, the PulseAgent.exe appears in the Bootdrv 
directory and the PulseAgent service is started. 

Once you install the PulseAgent plug-in, you define the speed of service target, in minutes 
and seconds, at which to turn the graphical charts in Pulse to red. 

Released 
Version

Tracking 
Number

Products Audience

AK 
v19.2.11

ALOHAP-15251 Aloha Kitchen, Aloha Quick Service, Aloha 
Table Service, Pulse

Configuration Technician
End User



 Aloha Kitchen v19.3
Defining AK speed of service target for NCR Pulse

28

Confidential and proprietary information of NCR.
Unauthorised use, reproduction and/or distribution is strictly prohibited.

To define the speed of service target in Aloha Kitchen:

1. With Kitchen selected in the product panel, select Maintenance > Kitchen 
Configuration > Kitchen Settings. 

2. Under the ‘Pulse speed of service’ group bar, type the number of minutes to use for the 
target speed of service in ‘Target minutes.’ 

Target minutes — Specifies the target speed of service minutes for an order, from start to
bump, before the lines on graphical charts in Pulse turn to red. The default is 0 (zero).
Related Options: To specify the number of seconds for the target time, enter the number in
‘Target seconds.’ Related Requirements: You must be a Pulse user to use this feature. Docu-
mented Version: AK v19.3.

3. Type the number of seconds in ‘Target seconds’ to use for the target time for the speed 
of service. 

Target seconds — Specifies the target speed of service seconds for an order, from start to
bump, before the lines on graphical charts in Pulse turn to red. The default is 0 (zero).
Related Options: To specify the number of minutes for the target time, enter the number in
‘Target minutes.’ Related Requirements: You must be a Pulse user to use this feature. Docu-
mented Version: AK v19.3.

4. Click Save and exit the Kitchen Settings function. 

Figure 20  Kitchen Settings Function
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In the Pulse app, if an order exceeds the targeted minutes and seconds, the lines appear in 
red on the graphical charts. 

Figure 21  Pulse Tile Examples 
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Printing rewards member on production or order taker chit 

Effective in Aloha Kitchen v19.2, you can use Print Designer to configure text, such as 
‘Rewards Member,’ to print on a production or order taker chit. The text prints when you 
assign a customer who has a Loyalty account to the check in the Aloha POS. The member 
number and any accrued or remaining point information do not print.  

Released 
Version

Tracking 
Number

Products Audience

AK v19.2 ALOHAP-18372
ALOHAP-23608

Aloha Kitchen, Aloha Quick Service, Aloha 
Table Service

Configuration Technician
End User

Figure 22  Rewards Member Text on Chit
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To define the custom text to use for the ‘Rewards member’ print designer element: 

1. With Kitchen selected in the product panel, select Maintenance > Kitchen 
Configuration > Kitchen Settings.  

2. Under the ‘Orders’ group bar, type the text to print on the chit in Reward member text.’ 

Reward member text — Specifies the text to print on a production and order taker chit
when you assign a Loyalty member to the check in the Aloha POS. Default: Rewards Mem-
ber. Required Options: 1) You must use a production chit or order taker chit layout in the
Print Designer function to use this option. 2) You must add the ‘Reward member text’ ele-
ment in the Print Designer function to use this option. Documented Version: AK 19.3.

3. Click Save and exit the Kitchen Settings function. 

To add the Reward Member Text element to a production or order taker chit layout: 

1. With Kitchen selected in the product panel, select Maintenance > Hardware > Print 
Designer Configuration > Print Designer. 

2. Select a production chit or order taker chit in use. 

Figure 23  Kitchen Settings
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3. Select the Design tab. 

4. Under the ‘Design’ group bar, click the Add drop-down arrow, select Reward member 
text, and click OK. The element is added to the layout. 

Reward member text — Prints the text to indicate the consumer is a Loyalty rewards
member. You must assign the consumer to the check in the Aloha POS to populate this ele-
ment. Default Alignment: Center. Related Options: You can customize the text to print using
‘Reward member text’ in Maintenance > Kitchen Configuration > Kitchen Settings. Docu-
mented Version: AK v19.3. 

5. Click Move Up and Move Down to position the element on the chit. 

6. Under the ‘Print style settings’ group bar, configure the remaining options as you would 
any other element. 

7. Click Save. 

8. Repeat this procedure for any other production or order taker chit layout for which to 
add the ‘Reward member text’ element. 

9. Exit the Print Designer function. 

Figure 24  Print Designer - Reward Member Text Element
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Supporting ‘Custom paid line text’ element 

Currently, when you tender a check, *** PAID *** appears on the printed kitchen chit, even 
when using the ‘Is paid’ element in Print Designer to customize your kitchen chit. Effective in 
Aloha Kitchen v19.2, you can use the ‘Custom paid line text’ element in Print Designer to 
define the text to appear on the kitchen chit when a check is tendered, such as PAID OUT. 

To configure the ‘Custom paid line text’ element: 

1. With Kitchen selected in the product panel, select Maintenance > Hardware > Print 
Designer Configuration > Print Designer. 

2. Select a layout that uses the ‘Production chit’ layout. 

3. Select the Design tab. 

4. Under the ‘Design’ group bar, click the Add drop-down arrow, select Custom paid line 
text, and click OK. The element is added to the layout. 

Released 
Version

Tracking 
Number

Products Audience

AK v19.2 ALOHAP-18376 Aloha Kitchen, Aloha Quick Service, Aloha 
Table Service

Configuration Technician
End User

Figure 25  Custom Paid Line Text Element
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Custom paid line text — Allows you to define the text to appear on the chit when a check
is tendered, such as ‘PAID OUT.’ Use this element instead of the ‘Is paid’ element. Default
Alignment: Center. Required Options: You must select ‘Show paid indicator’ in Maintenance
> Hardware > Kitchen Screen under the ‘Order display’ group bar. Documented Version: AK
v19.3.

5. Click Move Up and Move Down to position the element on the layout. 

6. Under the ‘Print style settings’ group bar, configure the remaining options as you would 
any other element. 

7. Under the ‘Custom paid line settings’ group bar, type the text to appear on the chit 
when a check is tendered in ‘Text.’ 

8. Click Save. 

9. Repeat this procedure for any other layout for which to add the ‘Custom paid line text’ 
element. 

10. Exit the Print Designer function. 
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Supporting Windows printer for drivers 

Effective in Aloha® Kitchen v19.2, we support installation of the Epson TM-88 printer with 
Windows® printer drivers. These drivers have proven to print text and graphical images on a 
chit with more clarity. We recommend you use an Ethernet connection for your operations 
since an Epson TM-88 printer installed with Windows printer drivers may print slower in 
comparison to other printers. 

Using this implementation, you can also configure font attributes that override the default 
font and font size options for an element in the Print Designer function. For example, if you 
select ‘Large’ as the font size for an element in Print Designer, you can stipulate the font size 
for large as being 15 points in the Windows printer definition. While there is no option in the 
Print Designer function to specify the font type, you can override the default font using ‘Font 
name’ in the Windows printer definition.

Released 
Version

Tracking 
Number

Products Audience

AK v19.2 ALOHAP-18509 Aloha Kitchen, Aloha Quick Service, Aloha 
Table Service

Configuration Technician
End User
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To configure a Windows printer:

1. With Kitchen selected in the product panel, select Maintenance > Hardware > Printers. 

2. Click the New drop-down arrow, select Aloha Kitchen, and click OK.  

3. Type a name to identify the printer. 

4. Under the ‘Settings’ group bar, select Windows Printer from the ‘Mode’ drop-down list 
to expose the ‘Windows printer settings’ group bar. 

5. Select the terminal that uses the printer. 

6. Select the backup printer to use for the terminal. 

7. Under the ‘Windows printer settings’ group bar, type a name to identify the printer in 
‘Printer name.’ 

Printer name — Uniquely identifies the printer. Documented Version: AK v19.3.

8. Select a font to use from the ‘Font name’ drop-down list, if desired. 

Font name — Specifies the font to use instead of the default font for chit printing. Docu-
mented Version: AK v19.3.

Figure 26  Printers - Printers Tab
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9. Select a font size to use for very small printing from the ‘Font size (very small)’ 
drop-down list, if desired. 

Font size (very small) — Specifies the font size to use for very small printing. The default is
5 points. Required Options: This option overrides the default font size used for the ‘Very
small’ choice for ‘Size’ on the Design tab in the Print Designer function. Documented Ver-
sion: AK v19.3.

10. Select a font size to use for small printing from the ‘Font size (small)’ drop-down list, if 
desired. 

Font size (small) — Specifies the font size to use for small printing. The default is 7 points.
Required Options: This option overrides the default font size used for the ‘Small’ choice for
‘Size’ on the Design tab in the Print Designer function. Documented Version: AK v19.3.

11. Select a font size to use for medium printing from the ‘Font size (medium)’ drop-down 
list, if desired. 

Font size (medium) — Specifies the font size to use for medium printing. The default is 10
points. Required Options: This option overrides the default font size used for the ‘Medium’
choice for ‘Size’ on the Design tab in the Print Designer function. Documented Version: AK
v19.3.

12. Select a font size to use for large printing from the ‘Font size (large)’ drop-down list, if 
desired. 

Font size (large) — Specifies the font size to use for large printing. The default is 13 points.
Required Options: This option overrides the default font size used for the ‘Large’ choice for
‘Size’ on the Design tab in the Print Designer function. Documented Version: AK v19.3.

13. Select a font size to use for very large printing from the ‘Font size (very large) 
drop-down list, if desired. 

Font size (very large) — Specifies the font size to use for very large printing. The default is
15 points. Required Options: This option overrides the default font size used for the ‘Very
large’ choice for ‘Size’ on the Design tab in the Print Designer function. Documented Version:
AK v19.3.

14. Click Save. 

15. Repeat this procedure for any other printer using a Windows printer. 

16. Exit the Printers function. 
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Printing consumer name on production chit 

Effective in Aloha Kitchen v19.3.6, you can print the consumer name to a production chit, 
using a custom production chit in Print Designer. You can customize the name in the 
following ways: 

● Print the first name only or not at all.

● Print the initials of the last name or not at all. 

● Print the first name and the initials of the last name on separate lines or not at all. 

● Configure the font size and style, as well as the alignment, of the consumer name on the 
chit.  

You capture the name of the consumer by naming a tab in Aloha Table Service or using the 
‘Name Order’ function in Aloha Quick Service. If you use Aloha Takeout and enable kitchen 
integration, Aloha Takeout passes the consumer name from the guest record and overrides 
the name entered in the POS system. 

Released 
Version

Tracking 
Number

Products Audience

AK v19.3.6 ALOHAP-18869 Aloha Kitchen, Aloha Quick Service, Aloha 
Table Service

Configuration Technician
End User

Figure 27  Initial for Last Name on Custom Chit

Reference:  Refer to the Aloha Kitchen and Aloha Takeout Integration Guide for information on 
configuring and using the Kitchen Integration feature.
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To customize the consumer name on a production chit:

1. With Kitchen selected in the product panel, select Maintenance > Hardware > Print 
Designer Configuration > Print Designer. 

2. Select a production chit layout from the drop-down list. 

3. Select the Design tab. 

4. Under the ‘Design’ group bar, click the Add drop-down arrow, select Customer first 
name, and click OK. 

Customer first name — Prints the first name of the consumer on the production chit.
Default Alignment: Left. Required Requirements: You must access Maintenance > System
Settings > Order Modes and select ‘Parse order name for customer name’ to use this option.
Documented Version: AK v19.3.6.

5. Click the Add drop-down arrow, select Customer last name first initial, and click OK. 

Customer last name first initial — Prints the initial of the last name of the consumer on
the production chit. Default Alignment: Left. Related Requirements: You must access Main-
tenance > System Settings > Order Mode > Kitchen tab and select ‘Parse order name for cus-
tomer name’ for each order mode to use this option. Documented Version: AK v19.3.6.

6. Click Move Up and Move Down to position the element on the layout. 

7. Under the ‘Print style settings’ group bar, configure the remaining options as you would 
for any other element. 

Figure 28  Print Designer - Design Tab
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8. Click Save. 

9. Repeat this procedure for any other layout to customize the consumer name on the 
production chit. 

10. Exit the Print Designer function. 

In addition to adding the elements to print the consumer name on the production chit in 
Print Designer, you must also select ‘Parse order name for customer name’ for the order 
modes you use. This allows the system to bypass internal naming conventions of a check, 
such as ‘table #,’ and check #.’ 

To configure an order mode to parse the order name:

1. With Kitchen selected in the product panel, select Maintenance > System Settings > 
Order Mode. 

2. Select an order mode from the drop-down list.

3. Select the Kitchen tab. 

4. Select Parse order name for customer name. 

Parse order name for customer name — Bypasses internal naming conventions of a
check, such as ‘table #’ and ‘check #,’ and allows the system to use Print Designer to print the
consumer name on a production chit. Related Requirements: You must add either the ‘Cus-
tomer first name’ or ‘Customer last name first initial’ element to a production chit in Print
Designer to use this option. Documented Version: AK v19.3.6

Figure 29  Order Mode - Kitchen Tab
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5. Click Save. 

6. Repeat this procedure for each order mode to parse the order name. 

7. Exit the Order Mode function. 
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Printing multiple bag chits for a single order 

This feature is still in development and is not fully functional. We will update the docu-
mentation when the feature reaches optimal functionality. 

Currently, Aloha Kitchen prints only one bag chit for attachment to an order; however, many 
restaurants have takeout orders that contain multiple bags. Effective in Aloha Kitchen v19.2, 
you can access a new screen to select the number of bag chits to print for a single order. 
Each chit prints the bag number and the total number of bag chits, such as Bag 1 of 3. 

To configure printing multiple bag chits for a single order:

1. With Kitchen selected in the product panel, select Maintenance > Kitchen 
Configuration > Kitchen Settings. 

2. Select Confirm Last Bump Item. 

Confirm last bump item — 

3. Select Bag Chit Screen for Confirm Order Screen.

Bag chit screen for confirm order screen — 

4. Type the number of bag chits you want to print for a single order in ‘Number of bag chit 
buttons on confirm order screen.

Number of bag chit buttons on confirm order screen — 

5. Click Save and exit the Kitchen Settings function. 

To add the bag chit number to a custom print layout:

1. With Kitchen selected in the product panel, select Maintenance > Hardware > Print 
Designer Configuration > Print Designer. 

2. Select a layout in use from the drop-down list. 

3. Under the ‘Design’ group bar, click the Add drop-down arrow, select Bag chit, and click 
OK. The element is added to the layout. 

4. Click Move Up and Move Down to position the element on the layout. 

Released 
Version

Tracking 
Number

Products Audience

AK v19.2 ALOHAP-19992 Aloha Kitchen, Aloha Quick Service, Aloha 
Table Service

Configuration Technician
End User
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5. Under the ‘Print style settings’ group bar, configure the remaining options as you would 
any other element. 

6. Click Save. 

7. Repeat this procedure for any other layout for which to add the ‘Custom paid line text’ 
element. 

8. Exit the Print Designer function. 
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Disabling bump bars by station for staff levels 

This feature is still in development and is not fully functional. We will update the docu-
mentation when the feature reaches optimal functionality. 

You can use staff levels in Aloha Kitchen to make operational changes by targeting specific 
kitchen stations in use; however, the bump bars at the station are still operational. Effective 
in Aloha Kitchen v19.2, you can disable the bump bar at the station so it does not respond to 
a bump bar command press. 

To disable bump bars by station for staff levels:

1. With Kitchen selected in the product panel, select Maintenance > Kitchen 
Configuration > Staff Levels. 

2. Select a staff level from the drop-down list. 

3. Select Disabled bump bars. 

4. Click Save. 

5. Repeat this procedure for each staff level you want to disable bump bars. 

6. Exit the Staff Levels function. 

Released 
Version

Tracking 
Number

Products Audience

AK v19.2 ALOHAP-21530 Aloha Kitchen, Aloha Quick Service, Aloha 
Table Service

Configuration Technician
End User

<AlohaKitchenOverlay>
<StaffLevel>
<Number>3</Number>
<DisabledBumpBars>8201,8101,8102</DisabledBumpBars>
</StaffLevel>
</AlohaKitchenOverlay>
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Displaying checked-in icon and text on video screen

When you integrate Aloha® Kitchen with Aloha Takeout, you can implement a curbside or 
call-ahead environment where the kitchen is notified when the guest arrives at the 
restaurant. This is usually triggered through a ‘checked-in’ function within Aloha Takeout 
and the message is then sent to Aloha Kitchen. 

Effective in Aloha Kitchen v19.3.6, a checked-in icon and custom text can appear on a 
header or footer layout of the video cell. This notifies the kitchen staff when a customer 
arrives and is waiting for their order, so they can prioritize and act appropriately.  

Released 
Version

Tracking 
Number

Products Audience

AK v19.3.6 ALOHAP-23513 Aloha Kitchen, Aloha Quick Service, Aloha 
Table Service, Aloha Takeout

Configuration Technician
End User

Figure 30  Checked In Indicator on Header and Footer Layout

Reference:  Refer to the Curbside Management Feature Focus Guide for more information on the 
Curbside functionality. You can also refer to the Aloha Takeout and Aloha Kitchen Integration Guide 
for information. 
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To configure a kitchen screen to display a ‘checked in indicator and text’: 

1. With Kitchen selected in the product panel, select Maintenance > Hardware > Kitchen 
Screen. 

2. Select a kitchen screen in use. 

3. Under the ‘Display options’ group bar, type the text to use when a consumer arrives to 
pick up an order in ‘Customer checked in text.’ 

Customer checked in text — Denotes the text to appear when a consumer arrives to pick
up an order. The default message is “Customer Checked In.” Required Options: You must
select Maintenance > Kitchen Configuration > Header and Footer Layout and add the ‘Cus-
tomer checked in text’ to a header or footer layout to display the text on a video cell.
Related Requirements: You must select Maintenance > Takeout Configuration > Takeout
Settings > Options tab in Aloha Takeout and select ‘Enable kitchen integration’ to use this
feature. Documented Version: AK v19.3.

4. Select Show checked in to allow the kitchen screen to display a ‘checked in’ icon. 

Show Checked in — Allows a ‘checked in’ icon to appear on the kitchen screen. Required
Options: You must select Maintenance > Kitchen Configuration > Header and Footer Layout
and add the ‘Customer checked in icon’ to a header or footer layout to display the icon on a

Figure 31  Kitchen Screen Function
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video cell. Related Requirements: You must select Maintenance > Takeout Configuration >
Takeout Settings > Options tab in Aloha Takeout and select ‘Enable kitchen integration’ to
use this feature. Documented Version: AK v19.3.

5. Click Save. 

6. Repeat this procedure for other screens for which you want a checked in indicator and 
checked in text to appear. 

7. Exit the Kitchen Screen function. 

To configure checked in indicator to a video screen:

1. With Kitchen selected in the product panel, select Maintenance > Kitchen 
Configuration > Header and Footer Layout. 

2. Select a layout in use from the drop-down list. 

3. Select the Design tab. 

4. Under the ‘Elements’ group bar, click the Add drop-down arrow, select Customer 
checked in icon, and click OK. 

Customer checked in icon — Displays an image on the video cell to indicate a customer
has arrived to pick their order. Related Options: Typically, you configure this feature with the
‘Customer checked in text’ element. Related Requirements: You must select Maintenance >
Takeout Configuration > Takeout Settings > Options tab in Aloha Takeout and select ‘Enable
kitchen integration’ to use this feature. Documented Version: AK v19.3.

Figure 32  Header and Footer Layout - Customer Checked In Icon Element
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5. Click the Add drop-down arrow, select Customer checked in text and click OK. 

Customer checked in text — Displays text on the video cell to notify the kitchen a cus-
tomer has arrived and checked in. Related Options: Typically, you configure this feature with
the ‘Customer checked in icon’ element. Related Requirements: You must select Mainte-
nance > Takeout Configuration > Takeout Settings > Options tab in Aloha Takeout and select
‘Enable kitchen integration’ to use this feature. Documented Version: AK v19.3. 

6. Arrange the placement of the elements as you would for any other element on a layout. 

7. Click Save. 

8. Repeat this procedure for each layout for which to configure a ‘Customer checked in 
icon’ and ‘Customer checked in text’ element. 

9. Exit the Header and Footer Layout function. 
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Displaying vehicle information on video screen 

This feature is still in development and is not fully functional. We will update the docu-
mentation when the feature reaches optimal functionality. 

Effective in Aloha Kitchen v19.3.6, you can display the vehicle information that is propagated 
from Aloha Takeout on the video screen. 

To display vehicle information on a video screen:

1. With Kitchen selected in the product panel, select Maintenance > Hardware > Kitchen 
Screen. 

2. Select a kitchen screen from the drop-down list. 

3. Select Show vehicle information. 

Show vehicle information — Displays the vehicle information sent from the Aloha Takeout
product. Related Requirements: You must select ‘Enable kitchen integration’ in Aloha Take-
out to use this feature. 

4. Click Save. 

Released 
Version

Tracking 
Number

Products Audience

AK v19.3.6 ALOHAP-23512 Aloha Kitchen, Aloha Quick Service, Aloha 
Table Service

Configuration Technician
End User

Figure 33  Checked In Indicator on Header and Footer Layout
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5. Repeat this procedure for any other screen you want to show vehicle information. 

6. Exit the Kitchen Screen function. 

<KitchenScreen>
<Number>6</Number>
<ShowVehicleInformation>true</ShowVehicleInformation>
</KitchenScreen>
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